Please update your browser. Why?

FontShop keeps you safer

What happens?

Starting summer 2017, will no longer support TLS 1.0 for HTTPS protocol. Web browsers that do not support TLS v.1.1 or higher cannot access


Protecting your privacy is important to us. By upgrading to the stronger encryption, we safeguard and secure the transfer of your personal data in the best possible way.

Who is affected?

If you have regularly updated your system, you are on the safe side. Most current browsers support the new TLS versions. Only Apple Safari before version 7 and Microsoft Internet Explorer before version 11 (both introduced in 2013) do not support TLS version 1.1. If you are using one of these browsers and cannot update it, please go to using a recent version of Firefox or Google Chrome.